Szakkörök‎ > ‎Algoritmus szakkör‎ > ‎2015-2016‎ > ‎

24. alkalom

Gráfok és gráfreprezentációk





Mélységi bejárás

kezdetben minden v csúcsra bejárt[v] := hamis

dfs(v):
    bejárt[v] := igaz
    v feldolgozása
    Ciklus v minden w szomszédjára
        Ha bejárt[w] = hamis akkor dfs(w) Elágazás vége
    Ciklus vége
Eljárás vége

Feladat