Szakkörök‎ > ‎Algoritmus szakkör‎ > ‎2015-2016‎ > ‎

18. alkalom

A topologikus rendezés egy lehetséges algoritmusát beszéltük meg.

Mélységi bejárás

dfs(v)
    Ha nem bejárt(v) akkor
        bejárt(v) := igaz
        Ciklus minden v->w élen
            dfs(w)
        Ciklus vége
        verembe(v)
    Elágazás vége
Eljárás vége

Topologikus rendezés


Ciklus G minden v csúcsára
    dfs(v)
Ciklus vége

Ciklus amíg nem üres a verem
    u := veremből()
    KI( u )
Ciklus vége