Programozás‎ > ‎

Unió

Feladat

Bemenet

Adatok két sorozata tömbben, fájlban vagy standard bemeneten (X[1],X[2],…,X[M] és Y[1],Y[2],…,Y[N]).

Kimenet

A két sorozat (mint halmaz) uniója a Z[] tömbben. Itt érdemes végiggondolni, hogy megengedhető-e elemek ismétlődése (multihalmaz).

Algoritmusok

Adatok tömbben

DBZ := 0
Ciklus i := 1-től M-ig
    DBZ := DBZ + 1
    Z[DBZ] := X[i]
Ciklus vége
Ciklus i := 1-től N-ig
    j := 1
    Ciklus amíg j <= M és X[j] <> Y[i]
        j := j + 1
    Ciklus vége
    Ha j > M akkor
        DBZ := DBZ + 1
        Z[DBZ] := Y[i]
    Elágazás vége
Ciklus vége

Példák

Feladatok