Programozás‎ > ‎Rendezések‎ > ‎

Minimumkiválasztásos rendezés

Gondolat

A rendezés után az első helyre a legkisebb elem kerül. Tehát ha megtaláljuk a minimális elemet, becserélhetjük az első helyre. Ezután a második elemtől kezdődő résztömbben kell megkeresnünk a minimális elemet, és azt érdemes a második helyre cserélni....

A rendezés tehát futamokból fog állni. Egy futamban az i. indexű elemtől az utolsó elemig tartó rész minimumát keressük meg, és ezt az i. pozícióra cseréljük.


Algoritmus

Ciklus i := E-től (U-1)-ig
    min := i
    Ciklus j := (i+1)-től U-ig
        Ha a[j] < a[min] akkor min := j Elágazás vége
    Ciklus vége
    Csere(i, min)
Ciklus vége