Programozás‎ > ‎Rendezések‎ > ‎

Kupacrendezés

A kupac adatszerkezet használatával O(N log N)-es rendezés készíthető. 

kupacrendez(T,N):

    //kezdeti kupac felépítése

    Ciklus i := N/2-től 1-ig
        süllyeszt(i)
    Ciklus vége


    //maximális elemek helyretétele egymás után

    Ciklus i:=1-től (N-1)-ig
        csere(T,1,N-i+1)
        süllyeszt(1)
    Ciklus vége

eljárás vége