Programozás‎ > ‎

Összegzés

Feladat

Bemenet

Adatok sorozata tömbben, fájlban vagy standard bemeneten: X[E], X[E+1], ..., X[U]

Kimenet

A sorozat "összege". Ez legegyszerűbb esetben azt jelenti, hogy számokat adtunk össze.

Algoritmus

Adatok tömbben

S := 0
Ciklus i:=E-től U-ig
    S := S + X[i]
Ciklus vége

Adatok fájlban, előre adott a darabszám

Megnyit( bemenet )
S := 0
Ciklus i:=E-től U-ig
    X := Olvas( bemenet )
    S := S + X
Ciklus vége
Bezár( bemenet )

Adatok fájlban, ismeretlen darabszám

Megnyit( bemenet )
S := 0
Ciklus amíg nem Fájlvége( bemenet )
    X := Olvas( bemenet )
    S := S + X
Ciklus vége
Bezár( bemenet )

Kódok

Java

S = 0;
for(int i = E; i <= U; i++) {
    S += X[i]
}

Pascal

C

Gyakorlatok

  1. Egy fájlban egy cég alkalmazottainak fizetése van tárolva, soronként egy szám. Határozzuk meg, mennyit fizet ki összesen a cég dolgozóinak!
  2. Egy fájlban egy osztály tanulóinak informatika jegyeit tároljuk, soronként egyet. Határozzuk meg az osztályátlagot!
  3. Egy fájlban kétszer kettes valós elemű mátrixok vannak, soronként egy. A mátrix négy eleme szóközzel van elválasztva, először az első sor, utána a második sor elemei következnek, balról jobbra. Számoljuk ki a mátrixok szorzatát!