Programozás‎ > ‎

Metszet

Feladat

Bemenet

Adatok két sorozata tömbben, fájlban vagy standard bemeneten (X[1],X[2],…,X[M] és Y[1],Y[2],…,Y[N]).

Kimenet

A két sorozat (mint halmaz) metszete a Z[] tömbben. Itt érdemes végiggondolni, hogy megengedhető-e elemek ismétlődése az eredeti sorozatokban.

Algoritmusok

Adatok tömbben

DBZ := 0
Ciklus i := 1-től M-ig
    j := 1
    Ciklus amíg j <= N és X[i] <> Y[j]
        j := j + 1
    Ciklus vége
    Ha j <= N akkor
        DBZ := DBZ + 1
        Z[DBZ] := X[i]
    Elágazás vége
Ciklus vége

Példák

Feladatok