Programozás‎ > ‎

Megszámolás

Feladat

Bemenet

Adatok sorozata tömbben, fájlban vagy standard bemeneten (X[E], X[E+1], ..., X[U]), továbbá egy T tulajdonság, ami az adatokhoz egy logikai értéket rendel. Egyszerűbben: minden adatra kiszámítható, hogy a tulajdonság igaz vagy nem.

Kimenet

A T tulajdonságú adatok darabszáma.

Algoritmus

Adatok tömbben

DB := 0
Ciklus i := E-től U-ig
    Ha T(X[i]) akkor DB := DB + 1 Elágazás vége
Ciklus vége

Adatok fájlban

Megnyit( bemenet )
DB := 0
Ciklus amíg nincs vége a bemenetnek
    X := Olvas( bemenet )
    Ha T(X) akkor
        DB := DB + 1
    Elágazás vége
Ciklus vége
Bezár( bemenet )

Gyakorlatok