Programozás‎ > ‎

Maximumkeresés

Feladat

Bemenet

Adatok sorozata tömbben, fájlban vagy standard bemeneten (X[E], X[E+1],..., X[U]), továbbá értelmezett az adatokon egy rendezés: eldönthető két adatról, hogy melyik a nagyobb.

Kimenet

A(z egyik) legnagyobb adat sorszáma és/vagy értéke.

Algoritmus

Adatok tömbben, érték meghatározása

MAX := X[E]
Ciklus i := (E+1)-től U-ig
    Ha X[i] > MAX akkor MAX := X[i] Elágazás vége
Ciklus vége

Adatok tömbben, sorszám meghatározása

MAX_I := E
Ciklus i := (E+1)-től U-ig
    Ha X[i] > X[MAX_I] akkor MAX_I := i Elágazás vége
Ciklus vége

Adatok fájlban

Megnyit( bemenet )
X := Olvas( bemenet ) // feltesszük, hogy van legalább egy adat
MAX := X
Ciklus amíg nincs vége a bemenetnek
    X := Olvas( bemenet )
    Ha X > MAX akkor
        MAX := X
    Elágazás vége
Ciklus vége
Bezár( bemenet )

Gyakorlatok