Programozás‎ > ‎

Kiválasztás

Feladat

Bemenet

Adatok sorozata tömbben, fájlban vagy standard bemeneten (X[E], X[E+1], ..., X[U]), továbbá egy T tulajdonság, ami az adatokhoz egy logikai értéket rendel. Egyszerűbben: minden adatra kiszámítható, hogy a tulajdonság igaz vagy nem. Tudjuk, hogy van legalább egy T tulajdonságú adat.

Kimenet

Egy T tulajdonságú adat sorszáma (indexe) a SOR változóban.

Algoritmus

Adatok tömbben

i := E
Ciklus amíg nem T(X[i])
    i := i + 1
Ciklus vége
SOR := i

Adatok fájlban

Megnyit( bemenet )
i := 0
VAN := HAMIS
Ciklus amíg VAN = HAMIS
    X := Olvas( bemenet )
    i := i + 1
    Ha T(X) akkor
        VAN := IGAZ
    Elágazás vége
Ciklus vége
SOR := i
Bezár( bemenet )

Kódok

Java

Gyakorlatok

  1. Keressük meg egy szám legnagyobb nála kisebb osztóját!
  2. Adott egy név, határozzuk meg (naptár alapján), hogy mikor van (először) névnapja!