Programozás‎ > ‎

Eldöntés

Feladat

Bemenet

Adatok sorozata tömbben, fájlban vagy standard bemeneten (X[E], X[E+1], ..., X[U]), továbbá egy T tulajdonság, ami az adatokhoz egy logikai értéket rendel. Egyszerűbben: minden adatra kiszámítható, hogy a tulajdonság igaz vagy nem.

Kimenet

A VAN változó "igen" vagy egy "nem" értéke. Akkor "igen" a válasz, ha az adatok között legalább egyre teljesül a T tulajdonság. Ha egyikre sem teljesül, akkor "nem" a válasz.

Algoritmus

Adatok tömbben

i := E
Ciklus amíg i<=U és nem T(X[i])
    i := i + 1
Ciklus vége
VAN := (i<=U)

Adatok fájlban

Megnyit( bemenet )
VAN := HAMIS
Ciklus amíg nincs vége a bemenetnek és VAN = HAMIS
    X := Olvas( bemenet )
    Ha T(X) akkor
        VAN := IGAZ
    Elágazás vége
Ciklus vége
Bezár( bemenet )

Kódok

Java

Scanner be = new Scanner(new FileReader("bemenet.txt"));
boolean VAN = false;
while (be.hasNext() && !VAN) {
    int X = be.nextInt();
    if (T(X)) {
        VAN = true;
    }
}
be.close();

Pascal

C

Gyakorlatok

  1. Döntsük el egy számról, hogy prím-e!
  2. Döntsük el a hónapnevek sorozata alapján, hogy egy szó hónapnév-e!
  3. Döntsük el egy tanuló jegyei alapján, hogy kitűnő tanuló-e!
  4. Döntsük el egy karakterláncról, hogy csak számjegyekből áll-e!
  5. Döntsük le egy sorozatról, hogy növekvően rendezett-e!
  6. Döntsük el egy karakterláncról, hogy palindrom-e!