Programozás‎ > ‎Dolgozatok‎ > ‎

C08 dolgozat 2011.11.08.

Ez a feladatsor a "papíros" dolgozat feladat-típusait mutatja be. Jóval több példa szerepel benne, mint ami egy 45 perces dolgozatban lenne.


Algoritmusok

Mit ír ki?

Mit számolnak ki (és írnak ki) az alábbi algoritmusok?

A.

BE(N)
H := 1; K := 0    
Ciklus amíg K < N
    H := H*3
    K := K + 1
Ciklus vége
KI(H)

B.

BE(N)
P := 1; T := 1
Ciklus amíg T+2 <= N
    T := T + 2
    P := P*T
Ciklus vége
KI(P)

C.

BE(X)
Y := 1
Ciklus amíg Y < X
    Y := Y*2
Ciklus vége
Y:= Y-1
KI(Y)

D.

BE(X)
Y := 1; Z := 1
Ciklus amíg Z < X
    Z := Z + Y
    Y := Z - Y
Ciklus vége
KI(Y)

E.

Eljárás:
    Be(X); BE(Y)
    Z:=1
    Ciklus amíg Y<>0
        Ha Y páratlan
            akkor Y:=Y-1 : Z:=Z*X
            különben X:=X*X : Y:=Y/2
         Elágazás vége
     Ciklus vége
    Ki(Z)
Eljárás vége

Java nyelv

Számítások

Mit írnak ki a következő parancsok a képernyőre?

A.

int a = 3, b = 4;
System.out.println(a+b);

B.

int a = 3, b = 4;
System.out.println(a+" "+b);

C.

int a = 3, b = 4;
System.out.println(a/b);

D.

int a = 3, b = 4;
int c = a/b;
System.out.println(c);

E.

int a = 3, b = 4;
double c = a/b;
System.out.println(c);

F.

double T = 10.0;
long a = (long) Math.sqrt(T);
System.out.println(a);

G.

int a = 3, b = 4;
System.out.print(a);
System.out.print(b);

H.


class miez{
     public static void main(String args[]){
         int A = Integer.parseInt(args[0]);
         int B = Integer.parseInt(args[1]);
        A=A+B;B=A-B;A=A-B;
        System.out.println(A+" "+B);
    }
}

I.

class miez
    public static void main(String args[]){
        int A = Integer.parseInt(args[0]);
        int B = Integer.parseInt(args[1]);
        int C = Integer.parseInt(args[2]);
        int X;

        if( A > B  ) {X=A; A=B; B=X}
        if( A > C  ) {X=A; A=C; C=X}
        if( C > B  ) {X=C; C=B; B=X}

        System.out.println(A+" "+B+" "+C);
      }
}

Mi a hiba?


if(a > b > c) {max = a}


if(a != 0 & D>=0) {System.out.println("OK");}


int sz = 1, n = 3;
double hanyados = sz/n;

int a = 42;
System.out.println(a+1)
System.out.println(a+2)
System.out.println(a+3)



Comments